3.x 升级与兼容性指南

快速了解 Dubbo3 的升级步骤与兼容性

无需改动任何代码,直接升级到 Dubbo 3.0。

在 3.0 版本的设计与开发之初,我们就定下了兼容老版本 Dubbo 用户(2.5、2.6、2.7)的目标。因此,往 3.0 版本的升级过程将会是完全透明的,用户无需做任何业务改造,升级 3.x 后的框架行为将保持与 2.x 版本完全一致。

<dependency>
  <groupId>org.apache.dubbo</groupId>
  <artifactId>dubbo</artifactId>
  <version>3.0.0</version>
</dependency>

但也要注意,透明升级仅仅是通往 3.0 的第一步,因为 “框架行为保持一致” 也就意味着用户将无法体验到 3.0 的新特性。如果要启用 3.0 的带来的新特性,用户则需要进行一定的改造,我们称这个过程为迁移,这是一个按需开启的过程。

因此,对老用户而言,有两条不同的迁移路径:

  • 分两步走,先以兼容模式推动业务升级到 3.0 版本(无需改造),之后在某些时机按需启用新特性(按需改造);
  • 升级与迁移同步完成,在业务升级到 3.0 版本的同时,完成改造并启用新特性;

Dubbo 3.0 提供的新特性包括: